Subscribed unsubscribe Subscribe Subscribe

k-yamadaのブログ

プログラミングのメモ

ruby1.9の標準jsonライブラリは、jsonが20以上ネストしているとparseできない

参考:https://groups.google.com/forum/?fromgroups#!topic/openwferu-users/qOCgF9InD_M

エラーメッセージ
nesting of 20 is too deep

対処方法
max_nestingオプションを付けてparseする
h = JSON.parse(s, :max_nesting => 100)